#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\S+\[v=\"(timeSeries)-(\w+)\",g=\"(\w+)\",p=\"(\S+)\"\]\S+array\[(\d+)\]\/(\S+)"
Local $sString = "root/12-825-ReturnAndStatsCompositeAPI[v="timeSeries-return",g="timeSeries",p="{"rollingPeriod":"1Y","numberOfPeriods":"5","asOfDate":"2016-12-31","startDate":"2011-12-31","frequency":"1Y"}"]/data/share_classes/array[1]/returns_series/returns/array[1]/net/cumulative" & @CRLF & _
"" & @CRLF & _
"root/2-825-ReturnAndStatsCompositeAPI[v="timeSeries-benchmark",g="timeSeries",p="{"rollingPeriod":"1Y","column":"column","numberOfPeriods":"5","asOfDate":"2016-12-31","startDate":"2011-12-31","frequency":"1Y"}"]/data/share_classes/array[1]/benchmark_types/benchmark_types_breakdown/array[3]/returns_series/returns/array[1]/gross/annualized" & @CRLF & _
"" & @CRLF & _
"root/2-825-ReturnAndStatsCompositeAPI[v="timeSeries-benchmark",g="timeSeries",p="{"rollingPeriod":"1Y","column":"column","numberOfPeriods":"5","asOfDate":"2016-12-31","startDate":"2011-12-31","frequency":"1Y"}"]/data/share_classes/array[1]/benchmark_types/benchmark_types_breakdown/array[3]/mpt_statistics_series/relative/gross/array[1]/excess_return" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")