re = /<.*?>/m
str = '<span class=\'test\'>
HTML tag was detected, as you can see.
</span>
<b>bold stuff</b>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end