package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<.*?>`)
var str = `<span class='test'>
HTML tag was detected, as you can see.
</span>
<b>bold stuff</b>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}