$re = '/<.*?>/m';
$str = '<span class=\'test\'>
HTML tag was detected, as you can see.
</span>
<b>bold stuff</b>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);