// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^(-?)(\d{1,})((\.\d{0,2})?))$").unwrap();
let string = "123.09
123.2345
123.09
-12.23
-100
100
12356
123567678
0
0.00";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}