using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^(-?)(\d{1,})((\.\d{0,2})?))$";
string input = @"123.09
123.2345
123.09
-12.23
-100
100
12356
123567678
0
0.00";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}