$re = '/(^(-?)(\d{1,})((\.\d{0,2})?))$/m';
$str = '123.09
123.2345
123.09
-12.23
-100
100
12356
123567678
0
0.00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);