re = /::([^.]*?)::/m
str = 'Ma chaine de ::caractè res:: dans laquelle je dois ::trouver:: le modèle je dois trouver: le modèle'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end