using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"::([^.]*?)::";
string input = @"Ma chaine de ::caractè res:: dans laquelle je dois ::trouver:: le modèle je dois trouver: le modèle";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}