$re = '/::([^.]*?)::/m';
$str = 'Ma chaine de ::caractè res:: dans laquelle je dois ::trouver:: le modèle je dois trouver: le modèle';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);