import Foundation
let pattern = #"(^[A-Z][0-9]{6})\s([0-9]{2}:[0-9]{2}:[0-9]{2}.[0-9]{6})\s([0-9]{4})\s([a-z]*\/[a-z]*_[a-z]*.go:[0-9]*)\s\s(\[[a-z]*[0-9]*,[a-z]*=[0-9]*[0-9]\.[0-9]*\.[0-9]*\.[0-9]*:[0-9]*,[a-z]*,[a-z]*=[a-z]*\])\s([0-9])*\s([a-z]*)\s(".*?")\s(\{".*?\})\s(".*?")\s(\{\})\s([0-9]*.[0-9]*)\s([0-9*])\s([A-Z]*)\s([0-9]*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"I220430 05:12:06.367747 2604 sql/exec_log.go:188 [n1,client=127.0.0.1:40190,hostnossl,user=root] 2 exec "$ cockroach sql" {"imperva"[52]:READWRITE} "INSERT INTO imperva(ice_cream, ramen, pizza) VALUES ('mister', 'motomachi', 'pizzeria farina')" {} 4.714 1 OK 0"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)