package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^[A-Z][0-9]{6})\s([0-9]{2}:[0-9]{2}:[0-9]{2}.[0-9]{6})\s([0-9]{4})\s([a-z]*\/[a-z]*_[a-z]*.go:[0-9]*)\s\s(\[[a-z]*[0-9]*,[a-z]*=[0-9]*[0-9]\.[0-9]*\.[0-9]*\.[0-9]*:[0-9]*,[a-z]*,[a-z]*=[a-z]*\])\s([0-9])*\s([a-z]*)\s(".*?")\s(\{".*?\})\s(".*?")\s(\{\})\s([0-9]*.[0-9]*)\s([0-9*])\s([A-Z]*)\s([0-9]*)`)
var str = `I220430 05:12:06.367747 2604 sql/exec_log.go:188 [n1,client=127.0.0.1:40190,hostnossl,user=root] 2 exec "$ cockroach sql" {"imperva"[52]:READWRITE} "INSERT INTO imperva(ice_cream, ramen, pizza) VALUES ('mister', 'motomachi', 'pizzeria farina')" {} 4.714 1 OK 0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}