import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^[A-Z][0-9]{6})\\s([0-9]{2}:[0-9]{2}:[0-9]{2}.[0-9]{6})\\s([0-9]{4})\\s([a-z]*\\/[a-z]*_[a-z]*.go:[0-9]*)\\s\\s(\\[[a-z]*[0-9]*,[a-z]*=[0-9]*[0-9]\\.[0-9]*\\.[0-9]*\\.[0-9]*:[0-9]*,[a-z]*,[a-z]*=[a-z]*\\])\\s([0-9])*\\s([a-z]*)\\s(\".*?\")\\s(\\{\".*?\\})\\s(\".*?\")\\s(\\{\\})\\s([0-9]*.[0-9]*)\\s([0-9*])\\s([A-Z]*)\\s([0-9]*)";
final String string = "I220430 05:12:06.367747 2604 sql/exec_log.go:188 [n1,client=127.0.0.1:40190,hostnossl,user=root] 2 exec \"$ cockroach sql\" {\"imperva\"[52]:READWRITE} \"INSERT INTO imperva(ice_cream, ramen, pizza) VALUES ('mister', 'motomachi', 'pizzeria farina')\" {} 4.714 1 OK 0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}