# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[a-zA-Z0-9._-]{1,99}(@)[a-zA-Z0-9]{1,99}(.)[a-zA-Z]{1,3}"
test_str = ("lama.loca.loca123@inca.com\n\n"
"pio_pio@factory.com\n\n"
"carnival666@hellmail.com\n\n"
"la-lalai@gmail.com\n\n"
"//INVALID EMAILS\n"
"//spaces at start\n"
" testmail@mail.com\n\n"
"//start with points\n"
".testmail@mail.com\n\n"
"//finish with points\n"
"testmail@mail.com.\n\n"
"//spaces into the string\n"
"testm ail@mail.com\n\n"
"//Start/finish with any not number|letter char\n\n"
"testmail@mail.com.de\n"
"testmail@mail.de.org")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.