use strict;
my $str = 'lama.loca.loca123@inca.com
pio_pio@factory.com
carnival666@hellmail.com
la-lalai@gmail.com
//INVALID EMAILS
//spaces at start
testmail@mail.com
//start with points
.testmail@mail.com
//finish with points
testmail@mail.com.
//spaces into the string
testm ail@mail.com
//Start/finish with any not number|letter char
testmail@mail.com.de
testmail@mail.de.org';
my $regex = qr/[a-zA-Z0-9._-]{1,99}(@)[a-zA-Z0-9]{1,99}(.)[a-zA-Z]{1,3}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}