import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-zA-Z0-9._-]{1,99}(@)[a-zA-Z0-9]{1,99}(.)[a-zA-Z]{1,3}";
final String string = "lama.loca.loca123@inca.com\n\n"
+ "pio_pio@factory.com\n\n"
+ "carnival666@hellmail.com\n\n"
+ "la-lalai@gmail.com\n\n"
+ "//INVALID EMAILS\n"
+ "//spaces at start\n"
+ " testmail@mail.com\n\n"
+ "//start with points\n"
+ ".testmail@mail.com\n\n"
+ "//finish with points\n"
+ "testmail@mail.com.\n\n"
+ "//spaces into the string\n"
+ "testm ail@mail.com\n\n"
+ "//Start/finish with any not number|letter char\n\n"
+ "testmail@mail.com.de\n"
+ "testmail@mail.de.org";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}