// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ix)\b
(?:
(?P<Name>ax|ay)
)
\s=\s
(?P<Wert1>\-?\s?[0-9]{1,2}\.?[0-9]?)
\s\[m\/s(?:²|2)\]
(?:
\s
(?P<Operator>\+|\-)
\s
(?P<Wert2>\-?\s?[0-9]{1,2}\.?[0-9]?)
\s\[m\/s(?:²|2)\]
|)").unwrap();
let string = "Fzg verzögern mit ax = -3 [m/s²] + 0.2 [m/s2]
Verzögerung verringern bis ax = -1.5 [m/s²] + 0.2 [m/s2]
Fzg beschleunigen mit ax = 3 [m/s²] - 0.2 [m/s2]
Fzg beschleunigen mit ax = 0.2 [m/s2]
Fzg langsam beschleunigen bis ax = 3 [m/s²] + 0.2 [m/s2]
Einlenken sodass ay = -3.5 [m/s²] + 0.2 [m/s2]
Langsam einlenken bis ay = -3.5 [m/s²] - 0.2 [m/s2]
Querbeschleunigung langsam verringern bis ay = - 1.8 [m/s²] + 0.2 [m/s2]
Längstbeschleunigung 3 [m/s2] //ax oder ay fehlt
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}