#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ix)\b" & @CRLF & _
"(?:" & @CRLF & _
"(?P<Name>ax|ay)" & @CRLF & _
")" & @CRLF & _
"\s=\s" & @CRLF & _
"(?P<Wert1>\-?\s?[0-9]{1,2}\.?[0-9]?)" & @CRLF & _
"\s\[m\/s(?:²|2)\]" & @CRLF & _
"(?:" & @CRLF & _
"\s" & @CRLF & _
"(?P<Operator>\+|\-)" & @CRLF & _
"\s" & @CRLF & _
"(?P<Wert2>\-?\s?[0-9]{1,2}\.?[0-9]?)" & @CRLF & _
"\s\[m\/s(?:²|2)\]" & @CRLF & _
"|)"
Local $sString = "Fzg verzögern mit ax = -3 [m/s²] + 0.2 [m/s2]" & @CRLF & _
"Verzögerung verringern bis ax = -1.5 [m/s²] + 0.2 [m/s2]" & @CRLF & _
"Fzg beschleunigen mit ax = 3 [m/s²] - 0.2 [m/s2]" & @CRLF & _
"Fzg beschleunigen mit ax = 0.2 [m/s2]" & @CRLF & _
"Fzg langsam beschleunigen bis ax = 3 [m/s²] + 0.2 [m/s2]" & @CRLF & _
"Einlenken sodass ay = -3.5 [m/s²] + 0.2 [m/s2]" & @CRLF & _
"Langsam einlenken bis ay = -3.5 [m/s²] - 0.2 [m/s2]" & @CRLF & _
"Querbeschleunigung langsam verringern bis ay = - 1.8 [m/s²] + 0.2 [m/s2]" & @CRLF & _
"Längstbeschleunigung 3 [m/s2] //ax oder ay fehlt" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")