$re = '/\b
(?:
(?P<Name>ax|ay)
)
\s=\s
(?P<Wert1>\-?\s?[0-9]{1,2}\.?[0-9]?)
\s\[m\/s(?:²|2)\]
(?:
\s
(?P<Operator>\+|\-)
\s
(?P<Wert2>\-?\s?[0-9]{1,2}\.?[0-9]?)
\s\[m\/s(?:²|2)\]
|)/ix';
$str = 'Fzg verzögern mit ax = -3 [m/s²] + 0.2 [m/s2]
Verzögerung verringern bis ax = -1.5 [m/s²] + 0.2 [m/s2]
Fzg beschleunigen mit ax = 3 [m/s²] - 0.2 [m/s2]
Fzg beschleunigen mit ax = 0.2 [m/s2]
Fzg langsam beschleunigen bis ax = 3 [m/s²] + 0.2 [m/s2]
Einlenken sodass ay = -3.5 [m/s²] + 0.2 [m/s2]
Langsam einlenken bis ay = -3.5 [m/s²] - 0.2 [m/s2]
Querbeschleunigung langsam verringern bis ay = - 1.8 [m/s²] + 0.2 [m/s2]
Längstbeschleunigung 3 [m/s2] //ax oder ay fehlt
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);