$re = '/^[-+]?([1-8]?\d(\.\d+)?|90?|90(\.0+)?){1}\s{1}[-+]?(180{1}|180(\.0+){1}|((1[0-7]\d{1})|([1-9]?\d){1})(\.\d+)?)\s?([-+]?(\d+(\.0+)?))?$/';
$str = '90 125 23';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);