package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[-+]?([1-8]?\d(\.\d+)?|90?|90(\.0+)?){1}\s{1}[-+]?(180{1}|180(\.0+){1}|((1[0-7]\d{1})|([1-9]?\d){1})(\.\d+)?)\s?([-+]?(\d+(\.0+)?))?$`)
var str = `90 125 23`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}