const regex = /^[-+]?([1-8]?\d(\.\d+)?|90?|90(\.0+)?){1}\s{1}[-+]?(180{1}|180(\.0+){1}|((1[0-7]\d{1})|([1-9]?\d){1})(\.\d+)?)\s?([-+]?(\d+(\.0+)?))?$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[-+]?([1-8]?\\d(\\.\\d+)?|90?|90(\\.0+)?){1}\\s{1}[-+]?(180{1}|180(\\.0+){1}|((1[0-7]\\d{1})|([1-9]?\\d){1})(\\.\\d+)?)\\s?([-+]?(\\d+(\\.0+)?))?$', 'g')
const str = `90 125 23`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}