re = /^<\w.*>/m
str = '<isInt>
<isStrf,\'dsifd\'>
<isNone, "df>
<isInt, \'a\', \'ss\'>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end