package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^<\w.*>`)
var str = `<isInt>
<isStrf,'dsifd'>
<isNone, "df>
<isInt, 'a', 'ss'>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}