import Foundation
let pattern = #"^((?:https?://(?:www\.)?|www\.)(?:(?!-)[A-Za-z0-9-]+\.[a-z]+)(?:\/[A-Za-z0-9-_]+\/?)*(?:[?&][A-Za-z0-9-\=\+_]+)*(?:\.[a-z]+)*)$|^((?:\d{1,3}\.){3}\d{1,3}(?:\:\d+)?)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://www.google.com
http://google.com
https://www.google.com
https://google.com
www.abcdefghijklmnopqrstuvwxyz123456789-.com
http://www.abcdefghijklmnopqrstuvwxyz123456789-.com
https://www.crummy.com/software/wow/
https://www.crummy.com/software?wow=1
https://www.crummy.com/software/examples/hello?wow=1&yep=ok
https://www.crummy.com/software?wow=1+and+2&yep=ok
https://www.crummy.com/software/BeautifulSoup/bs4/doc/_sources/index.txt
Outliers
http://www.google
http://wwww.google.com
http://ww.google.com
https://w.g.c
255.255.255.255:5555
192.168.9.50:22
127.0.0.1
127.0.0.1:8080
www.google
google.com
google
ww.google.c
ht://www.google.com
www.-google.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)