use strict;
my $str = 'http://www.google.com
http://google.com
https://www.google.com
https://google.com
www.abcdefghijklmnopqrstuvwxyz123456789-.com
http://www.abcdefghijklmnopqrstuvwxyz123456789-.com
https://www.crummy.com/software/wow/
https://www.crummy.com/software?wow=1
https://www.crummy.com/software/examples/hello?wow=1&yep=ok
https://www.crummy.com/software?wow=1+and+2&yep=ok
https://www.crummy.com/software/BeautifulSoup/bs4/doc/_sources/index.txt
Outliers
http://www.google
http://wwww.google.com
http://ww.google.com
https://w.g.c
255.255.255.255:5555
192.168.9.50:22
127.0.0.1
127.0.0.1:8080
www.google
google.com
google
ww.google.c
ht://www.google.com
www.-google.com
';
my $regex = qr/^((?:https?://(?:www\.)?|www\.)(?:(?!-)[A-Za-z0-9-]+\.[a-z]+)(?:\/[A-Za-z0-9-_]+\/?)*(?:[?&][A-Za-z0-9-\=\+_]+)*(?:\.[a-z]+)*)$|^((?:\d{1,3}\.){3}\d{1,3}(?:\:\d+)?)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}