import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:https?://(?:www\\.)?|www\\.)(?:(?!-)[A-Za-z0-9-]+\\.[a-z]+)(?:\\/[A-Za-z0-9-_]+\\/?)*(?:[?&][A-Za-z0-9-\\=\\+_]+)*(?:\\.[a-z]+)*)$|^((?:\\d{1,3}\\.){3}\\d{1,3}(?:\\:\\d+)?)$";
final String string = "http://www.google.com\n"
+ "http://google.com\n"
+ "https://www.google.com\n"
+ "https://google.com\n"
+ "www.abcdefghijklmnopqrstuvwxyz123456789-.com\n"
+ "http://www.abcdefghijklmnopqrstuvwxyz123456789-.com\n\n"
+ "https://www.crummy.com/software/wow/\n"
+ "https://www.crummy.com/software?wow=1\n"
+ "https://www.crummy.com/software/examples/hello?wow=1&yep=ok\n"
+ "https://www.crummy.com/software?wow=1+and+2&yep=ok\n\n"
+ "https://www.crummy.com/software/BeautifulSoup/bs4/doc/_sources/index.txt\n\n"
+ "Outliers\n"
+ "http://www.google\n"
+ "http://wwww.google.com\n"
+ "http://ww.google.com\n"
+ "https://w.g.c\n\n"
+ "255.255.255.255:5555\n"
+ "192.168.9.50:22\n"
+ "127.0.0.1\n"
+ "127.0.0.1:8080\n\n"
+ "www.google\n"
+ "google.com\n"
+ "google\n\n"
+ "ww.google.c\n"
+ "ht://www.google.com\n"
+ "www.-google.com\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}