import Foundation
let pattern = #"(?m)(?<_KEY_1>\w+[^:]+?)\s+:\s(?<_VAL_1>[^\r\n]+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Name : Mobile Broadband Connection
Description : Orange Mobile Broadband Device - Ice Cold with pulp Mmmmmmm
GUID : {12AE12A1-12CD-1BC1-A012-C1A1234CBE12}
Physical Address : 00:a0:c6:00:00:00
State : Connected
Device type : Mobile Broadband device is embedded in the system
Cellular class : CDMA
Device Id : T1231230088BD5E8
Manufacturer : Orange
Model : Orange 2000
Firmware Version : 4.1.2
Provider Name : Buttercup Wireless
Roaming : Not roaming
Signal : 48%
Device : 98
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)