package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?m)(?<_KEY_1>\w+[^:]+?)\s+:\s(?<_VAL_1>[^\r\n]+)$`)
var str = ` Name : Mobile Broadband Connection
Description : Orange Mobile Broadband Device - Ice Cold with pulp Mmmmmmm
GUID : {12AE12A1-12CD-1BC1-A012-C1A1234CBE12}
Physical Address : 00:a0:c6:00:00:00
State : Connected
Device type : Mobile Broadband device is embedded in the system
Cellular class : CDMA
Device Id : T1231230088BD5E8
Manufacturer : Orange
Model : Orange 2000
Firmware Version : 4.1.2
Provider Name : Buttercup Wireless
Roaming : Not roaming
Signal : 48%
Device : 98`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}