#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?m)(?<_KEY_1>\w+[^:]+?)\s+:\s(?<_VAL_1>[^\r\n]+)$"
Local $sString = " Name : Mobile Broadband Connection" & @CRLF & _
" Description : Orange Mobile Broadband Device - Ice Cold with pulp Mmmmmmm" & @CRLF & _
" GUID : {12AE12A1-12CD-1BC1-A012-C1A1234CBE12}" & @CRLF & _
" Physical Address : 00:a0:c6:00:00:00" & @CRLF & _
" State : Connected" & @CRLF & _
" Device type : Mobile Broadband device is embedded in the system" & @CRLF & _
" Cellular class : CDMA" & @CRLF & _
" Device Id : T1231230088BD5E8" & @CRLF & _
" Manufacturer : Orange" & @CRLF & _
" Model : Orange 2000" & @CRLF & _
" Firmware Version : 4.1.2" & @CRLF & _
" Provider Name : Buttercup Wireless" & @CRLF & _
" Roaming : Not roaming" & @CRLF & _
" Signal : 48%" & @CRLF & _
" Device : 98"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")