import Foundation
let pattern = #"(?P<event_message>A user account was locked out\.)\s+Subject:\s+Security ID:\s+(?P<subject_security_id>.*?)\s+Account Name:\s+(?P<subject_account_name>.*?)\s+Account Domain:\s+(?P<subject_account_domain>.*?)\s+Logon ID:\s+(?P<subject_logon_id>.*?)\s+Account That Was Locked Out:\s+Security ID:\s+(?P<locked_out_security_id>.*?)\s+Account Name:\s+(?P<locked_out_account_name>.*?)\s+Additional Information:\s+Caller Computer Name:\s+(?P<add_info_caller_computer_name>.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"A user account was locked out. Subject: Security ID: S-1-5-18 Account Name: WIN2K12-TEST$ Account Domain: WORKGROUP Logon ID: 0x3E7 Account That Was Locked Out: Security ID: S-1-5-21-2883959765-1550083997-3048789898-1018 Account Name: Test Additional Information: Caller Computer Name: NB00887902"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)