import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<event_message>A user account was locked out\\.)\\s+Subject:\\s+Security ID:\\s+(?P<subject_security_id>.*?)\\s+Account Name:\\s+(?P<subject_account_name>.*?)\\s+Account Domain:\\s+(?P<subject_account_domain>.*?)\\s+Logon ID:\\s+(?P<subject_logon_id>.*?)\\s+Account That Was Locked Out:\\s+Security ID:\\s+(?P<locked_out_security_id>.*?)\\s+Account Name:\\s+(?P<locked_out_account_name>.*?)\\s+Additional Information:\\s+Caller Computer Name:\\s+(?P<add_info_caller_computer_name>.*)";
final String string = "A user account was locked out. Subject: Security ID: S-1-5-18 Account Name: WIN2K12-TEST$ Account Domain: WORKGROUP Logon ID: 0x3E7 Account That Was Locked Out: Security ID: S-1-5-21-2883959765-1550083997-3048789898-1018 Account Name: Test Additional Information: Caller Computer Name: NB00887902";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}