$re = '/(?P<event_message>A user account was locked out\.)\s+Subject:\s+Security ID:\s+(?P<subject_security_id>.*?)\s+Account Name:\s+(?P<subject_account_name>.*?)\s+Account Domain:\s+(?P<subject_account_domain>.*?)\s+Logon ID:\s+(?P<subject_logon_id>.*?)\s+Account That Was Locked Out:\s+Security ID:\s+(?P<locked_out_security_id>.*?)\s+Account Name:\s+(?P<locked_out_account_name>.*?)\s+Additional Information:\s+Caller Computer Name:\s+(?P<add_info_caller_computer_name>.*)/';
$str = 'A user account was locked out. Subject: Security ID: S-1-5-18 Account Name: WIN2K12-TEST$ Account Domain: WORKGROUP Logon ID: 0x3E7 Account That Was Locked Out: Security ID: S-1-5-21-2883959765-1550083997-3048789898-1018 Account Name: Test Additional Information: Caller Computer Name: NB00887902';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);