$re = '/0*(?:[1-9]\d*(?:\.\d*)?|\.0*[1-9]\d*)/';
$str = '2.5, 0.12 ,222.22, 00.98, 0.23, 12.00, 0.004, .0012, 1.0, 2.
BUT NOT
0, 0.0, 00.0, 0.00, 00.00, .0, 0.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);