using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"0*(?:[1-9]\d*(?:\.\d*)?|\.0*[1-9]\d*)";
string input = @"2.5, 0.12 ,222.22, 00.98, 0.23, 12.00, 0.004, .0012, 1.0, 2.
BUT NOT
0, 0.0, 00.0, 0.00, 00.00, .0, 0.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}