import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "0*(?:[1-9]\\d*(?:\\.\\d*)?|\\.0*[1-9]\\d*)";
final String string = "2.5, 0.12 ,222.22, 00.98, 0.23, 12.00, 0.004, .0012, 1.0, 2.\n"
+ "BUT NOT \n"
+ "0, 0.0, 00.0, 0.00, 00.00, .0, 0.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}