// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:--(?:help|version)|-(?:h\W|v\W))|(?:--?\w+:\w+)").unwrap();
let string = "-h
-help
-v
-version
--help
--version
-mail:moo
--mailer:mm";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}