#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:--(?:help|version)|-(?:h\W|v\W))|(?:--?\w+:\w+)"
Local $sString = "-h" & @CRLF & _
"-help" & @CRLF & _
"-v" & @CRLF & _
"-version" & @CRLF & _
"--help" & @CRLF & _
"--version" & @CRLF & _
"-mail:moo" & @CRLF & _
"--mailer:mm"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")