$re = '/(?:--(?:help|version)|-(?:h\W|v\W))|(?:--?\w+:\w+)/m';
$str = '-h
-help
-v
-version
--help
--version
-mail:moo
--mailer:mm';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);