$re = '/^(?:[1-9][0-9]?|1\d{2})$/m';
$str = '8
10
15
99
100
199
200
1000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);