package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[1-9][0-9]?|1\d{2})$`)
var str = `8
10
15
99
100
199
200
1000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}