#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[1-9][0-9]?|1\d{2})$"
Local $sString = "8" & @CRLF & _
"10" & @CRLF & _
"15" & @CRLF & _
"99" & @CRLF & _
"100" & @CRLF & _
"199" & @CRLF & _
"200" & @CRLF & _
"1000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")