re = /<a(.*?)href=('|\")([^\>]*).(jpe?g|png|gif|mp4|webp|bmp)('|\")(.*?)>/i
str = '<a href="https://localhost/test" target="_blank">TEST</a>
<a href="http://localhost/test.jpg" data-fancybox="fancybox" data-caption="">
<img src="https://localhost/test-400x400.jpg" alt="">
</a>
<a href="https://localhost/te.2er44.-.awd.wd.ddwadst.jpg">
<img src="https://localhost/test-400x400.jpg" alt="">
</a>
<a href="https://localhost/test.svg">
<img src="https://localhost/test-400x400.jpg" alt="">
</a>
<a href="https://localhost/test.gif">
<img src="https://localhost/test-400x400.jpg" alt="">
</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end