import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a(.*?)href=('|\\\")([^\\>]*).(jpe?g|png|gif|mp4|webp|bmp)('|\\\")(.*?)>";
final String string = "<a href=\"https://localhost/test\" target=\"_blank\">TEST</a>\n\n"
+ "<a href=\"http://localhost/test.jpg\" data-fancybox=\"fancybox\" data-caption=\"\">\n"
+ " <img src=\"https://localhost/test-400x400.jpg\" alt=\"\">\n"
+ "</a>\n\n"
+ "<a href=\"https://localhost/te.2er44.-.awd.wd.ddwadst.jpg\">\n"
+ " <img src=\"https://localhost/test-400x400.jpg\" alt=\"\">\n"
+ "</a>\n\n"
+ "<a href=\"https://localhost/test.svg\">\n"
+ " <img src=\"https://localhost/test-400x400.jpg\" alt=\"\">\n"
+ "</a>\n\n"
+ "<a href=\"https://localhost/test.gif\">\n"
+ " <img src=\"https://localhost/test-400x400.jpg\" alt=\"\">\n"
+ "</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}