# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\[(?:(\+[0-9]{1,2}|(?:I PRI|II DUO|III TRI|IV TET|V PEN)):? )?(.*)\]) (?:([0-9,]*)).*?\(([0-9:]{5})\)"
test_str = ("[II DUO: Blue Coral Ring] 14,479,777 Silver(Marketplace Registration Queue) (11:17)\n"
"[I PRI: Blue Coral Ring] 14,479,777 Silver(Marketplace Registration Queue) (11:17)\n"
"[Blue Coral Earringssss] sold to Kasumizu through a pre-order. (11:16)\n"
"[V PEN: Blue Coral Earringssss] sold to Kasumizu through a pre-order. (11:16)\n"
"[Blue Coral Earring] 4,999,999 Silver(Marketplace Registration Queue) (11:16) \n"
"[+5 Steel Combat Champron] 4,924,197 Silver(Marketplace Registration Queue) (11:15)\n"
"[Blue Coral Earring] 4,999,999 Silver(Marketplace Registration Queue) (11:16)\n"
"[[Ranger] Blue Coral Earring] 4,999,999 Silver(Marketplace Registration Queue) (11:16)\n"
"[+5 Steel Combat (nampron] 4,924,197 Silver(Marketplace Registration Queue) (11:15)\n"
"[+15 Vuria snortsword of Crimson Flame] 14,348,172 Silver(Marketplace Registration Queue) (11:10)\n"
"[Blue Coral Earring] 4,999,999 Silver(Marketplace Registration Queue) (11:16)\n"
"[[Berserker] Cavaro Clasic Set] 4,999,999 Silver(Marketplace Registration Queue) (11:16)\n"
"[Blue Coral Earring] 4,999,999 Silver(Marketplace Registration Queue) (11:16)\n"
"[Blue Coral Earring] 4,999,999 Silver(Marketplace Registration Queue) (11:16)\n"
"[Ring of Crescent Guardian(30 days)] 49,559,233 Silver(Marketplace Registration Queue) (11:16)\n"
"[Basilisk's Belt] 74,999,999 Silver(Marketplace Registration Queue) (11:16)\n"
"[Sharp Black Crystal Shard] 3,699,999 Silver(Marketplace Registration Queue) (11:16)\n"
"[Liverto Amulet] 8,999,999 Silver(Marketplace Registration Queue) (11:16)\n"
"[Liverto Amulet] 8,999,999 Silver(Marketplace Registration Queue) (11:16)\n"
"[snarp Black Crystal snard] 3,699,999 Silver(Marketplace Registration Queue) (11:16)\n"
"[Liverto Amulet] 8,999,999 Silver(Marketplace Registration Queue) (11:16)\n"
"[Liverto Amulet] 8,999,999 Silver(Marketplace Registration Queue) (11:16)\n"
"[Basilisk's Belt] 74,999,999 Silver(Marketplace Registration Queue) (11:16)\n"
"[Sharp Black Crystal Shard] 3,699,999 Silver(Marketplace Registration Queue) (11:16)\n"
"[Forest Fury] 3,699,999 Silver(Marketplace Registration Queue) (11:16)\n"
"[Blue Coral Earring] sold to Kasumizu through a pre-order. (11:16)\n"
"[Sharp Black Crystal Shard] sold to Laforet through a pre-order. (11:16)\n"
"[+15 Ultimate Agerian Shoes] 16,499,992 Silver(Marketplace Registration Queue) (11:16)\n"
"[Black Magic Crystal - Cobelinus] 7,472,292 Silver(Marketplace Registration Queue) (11:16)\n"
"[+15 Ultimate Agerian Gloves] 16,499,992 Silver(Marketplace Registration Queue) (11:16)\n"
"[Mark of Shadow] 6,339,996 Silver(Marketplace Registration Queue) (11:17)\n"
"[II DUO: Blue Coral Ring] 14,479,777 Silver(Marketplace Registration Queue) (11:17)")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.