#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?:\[(?:(\+[0-9]{1,2}|(?:I PRI|II DUO|III TRI|IV TET|V PEN)):? )?(.*)\]) (?:([0-9,]*)).*?\(([0-9:]{5})\)"
Local $sString = "[II DUO: Blue Coral Ring] 14,479,777 Silver(Marketplace Registration Queue) (11:17)" & @CRLF & _
"[I PRI: Blue Coral Ring] 14,479,777 Silver(Marketplace Registration Queue) (11:17)" & @CRLF & _
"[Blue Coral Earringssss] sold to Kasumizu through a pre-order. (11:16)" & @CRLF & _
"[V PEN: Blue Coral Earringssss] sold to Kasumizu through a pre-order. (11:16)" & @CRLF & _
"[Blue Coral Earring] 4,999,999 Silver(Marketplace Registration Queue) (11:16) " & @CRLF & _
"[+5 Steel Combat Champron] 4,924,197 Silver(Marketplace Registration Queue) (11:15)" & @CRLF & _
"[Blue Coral Earring] 4,999,999 Silver(Marketplace Registration Queue) (11:16)" & @CRLF & _
"[[Ranger] Blue Coral Earring] 4,999,999 Silver(Marketplace Registration Queue) (11:16)" & @CRLF & _
"[+5 Steel Combat (nampron] 4,924,197 Silver(Marketplace Registration Queue) (11:15)" & @CRLF & _
"[+15 Vuria snortsword of Crimson Flame] 14,348,172 Silver(Marketplace Registration Queue) (11:10)" & @CRLF & _
"[Blue Coral Earring] 4,999,999 Silver(Marketplace Registration Queue) (11:16)" & @CRLF & _
"[[Berserker] Cavaro Clasic Set] 4,999,999 Silver(Marketplace Registration Queue) (11:16)" & @CRLF & _
"[Blue Coral Earring] 4,999,999 Silver(Marketplace Registration Queue) (11:16)" & @CRLF & _
"[Blue Coral Earring] 4,999,999 Silver(Marketplace Registration Queue) (11:16)" & @CRLF & _
"[Ring of Crescent Guardian(30 days)] 49,559,233 Silver(Marketplace Registration Queue) (11:16)" & @CRLF & _
"[Basilisk's Belt] 74,999,999 Silver(Marketplace Registration Queue) (11:16)" & @CRLF & _
"[Sharp Black Crystal Shard] 3,699,999 Silver(Marketplace Registration Queue) (11:16)" & @CRLF & _
"[Liverto Amulet] 8,999,999 Silver(Marketplace Registration Queue) (11:16)" & @CRLF & _
"[Liverto Amulet] 8,999,999 Silver(Marketplace Registration Queue) (11:16)" & @CRLF & _
"[snarp Black Crystal snard] 3,699,999 Silver(Marketplace Registration Queue) (11:16)" & @CRLF & _
"[Liverto Amulet] 8,999,999 Silver(Marketplace Registration Queue) (11:16)" & @CRLF & _
"[Liverto Amulet] 8,999,999 Silver(Marketplace Registration Queue) (11:16)" & @CRLF & _
"[Basilisk's Belt] 74,999,999 Silver(Marketplace Registration Queue) (11:16)" & @CRLF & _
"[Sharp Black Crystal Shard] 3,699,999 Silver(Marketplace Registration Queue) (11:16)" & @CRLF & _
"[Forest Fury] 3,699,999 Silver(Marketplace Registration Queue) (11:16)" & @CRLF & _
"[Blue Coral Earring] sold to Kasumizu through a pre-order. (11:16)" & @CRLF & _
"[Sharp Black Crystal Shard] sold to Laforet through a pre-order. (11:16)" & @CRLF & _
"[+15 Ultimate Agerian Shoes] 16,499,992 Silver(Marketplace Registration Queue) (11:16)" & @CRLF & _
"[Black Magic Crystal - Cobelinus] 7,472,292 Silver(Marketplace Registration Queue) (11:16)" & @CRLF & _
"[+15 Ultimate Agerian Gloves] 16,499,992 Silver(Marketplace Registration Queue) (11:16)" & @CRLF & _
"[Mark of Shadow] 6,339,996 Silver(Marketplace Registration Queue) (11:17)" & @CRLF & _
"[II DUO: Blue Coral Ring] 14,479,777 Silver(Marketplace Registration Queue) (11:17)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")