package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(?:\[(?:(\+[0-9]{1,2}|(?:I PRI|II DUO|III TRI|IV TET|V PEN)):? )?(.*)\]) (?:([0-9,]*)).*?\(([0-9:]{5})\)`)
var str = `[II DUO: Blue Coral Ring] 14,479,777 Silver(Marketplace Registration Queue) (11:17)
[I PRI: Blue Coral Ring] 14,479,777 Silver(Marketplace Registration Queue) (11:17)
[Blue Coral Earringssss] sold to Kasumizu through a pre-order. (11:16)
[V PEN: Blue Coral Earringssss] sold to Kasumizu through a pre-order. (11:16)
[Blue Coral Earring] 4,999,999 Silver(Marketplace Registration Queue) (11:16)
[+5 Steel Combat Champron] 4,924,197 Silver(Marketplace Registration Queue) (11:15)
[Blue Coral Earring] 4,999,999 Silver(Marketplace Registration Queue) (11:16)
[[Ranger] Blue Coral Earring] 4,999,999 Silver(Marketplace Registration Queue) (11:16)
[+5 Steel Combat (nampron] 4,924,197 Silver(Marketplace Registration Queue) (11:15)
[+15 Vuria snortsword of Crimson Flame] 14,348,172 Silver(Marketplace Registration Queue) (11:10)
[Blue Coral Earring] 4,999,999 Silver(Marketplace Registration Queue) (11:16)
[[Berserker] Cavaro Clasic Set] 4,999,999 Silver(Marketplace Registration Queue) (11:16)
[Blue Coral Earring] 4,999,999 Silver(Marketplace Registration Queue) (11:16)
[Blue Coral Earring] 4,999,999 Silver(Marketplace Registration Queue) (11:16)
[Ring of Crescent Guardian(30 days)] 49,559,233 Silver(Marketplace Registration Queue) (11:16)
[Basilisk's Belt] 74,999,999 Silver(Marketplace Registration Queue) (11:16)
[Sharp Black Crystal Shard] 3,699,999 Silver(Marketplace Registration Queue) (11:16)
[Liverto Amulet] 8,999,999 Silver(Marketplace Registration Queue) (11:16)
[Liverto Amulet] 8,999,999 Silver(Marketplace Registration Queue) (11:16)
[snarp Black Crystal snard] 3,699,999 Silver(Marketplace Registration Queue) (11:16)
[Liverto Amulet] 8,999,999 Silver(Marketplace Registration Queue) (11:16)
[Liverto Amulet] 8,999,999 Silver(Marketplace Registration Queue) (11:16)
[Basilisk's Belt] 74,999,999 Silver(Marketplace Registration Queue) (11:16)
[Sharp Black Crystal Shard] 3,699,999 Silver(Marketplace Registration Queue) (11:16)
[Forest Fury] 3,699,999 Silver(Marketplace Registration Queue) (11:16)
[Blue Coral Earring] sold to Kasumizu through a pre-order. (11:16)
[Sharp Black Crystal Shard] sold to Laforet through a pre-order. (11:16)
[+15 Ultimate Agerian Shoes] 16,499,992 Silver(Marketplace Registration Queue) (11:16)
[Black Magic Crystal - Cobelinus] 7,472,292 Silver(Marketplace Registration Queue) (11:16)
[+15 Ultimate Agerian Gloves] 16,499,992 Silver(Marketplace Registration Queue) (11:16)
[Mark of Shadow] 6,339,996 Silver(Marketplace Registration Queue) (11:17)
[II DUO: Blue Coral Ring] 14,479,777 Silver(Marketplace Registration Queue) (11:17)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}