use strict;
my $str = 'Tests:
Wordle 249 1/6
🟩🟩🟩🟩🟩
Wordle 251 6/6
⬛⬛⬛⬛⬛
⬛⬛🟨⬛⬛
⬛⬛🟨⬛⬛
⬛🟩🟩🟩⬛
⬛⬛⬛⬛⬛
🟩🟩🟩🟩🟩
Wordle 247 1/6
🟩🟩🟩🟩🟩
Wordle 1 5/6
⬛⬛⬛⬛⬛
⬛🟨⬛🟨🟨
⬛🟨⬛⬛⬛
🟨🟨🟨🟨🟨
🟩🟩🟩🟩🟩
Wordle 999 X/6
🟨🟩⬛⬛⬛
🟨🟩⬛⬛⬛
🟨🟩⬛⬛⬛
🟨🟩⬛⬛⬛
🟨🟩⬛⬛⬛
🟨🟩⬛⬛⬛';
my $regex = qr`Wordle\s(?P<number>\d+)\s(?P<tries>[1-6X])\/6(?:\r?\n){2}(?P<evaluations>(?:[⬛🟨🟩]{5}(?:\r?\n)){0,5})(?P<result>[⬛🟨🟩]{5})`p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}