import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Wordle\\s(?P<number>\\d+)\\s(?P<tries>[1-6X])\\/6(?:\\r?\\n){2}(?P<evaluations>(?:[⬛🟨🟩]{5}(?:\\r?\\n)){0,5})(?P<result>[⬛🟨🟩]{5})";
final String string = "Tests:\n\n"
+ "Wordle 249 1/6\n\n"
+ "🟩🟩🟩🟩🟩\n\n"
+ "Wordle 251 6/6\n\n"
+ "⬛⬛⬛⬛⬛\n"
+ "⬛⬛🟨⬛⬛\n"
+ "⬛⬛🟨⬛⬛\n"
+ "⬛🟩🟩🟩⬛\n"
+ "⬛⬛⬛⬛⬛\n"
+ "🟩🟩🟩🟩🟩\n\n"
+ "Wordle 247 1/6\n\n"
+ "🟩🟩🟩🟩🟩\n\n"
+ "Wordle 1 5/6\n\n"
+ "⬛⬛⬛⬛⬛\n"
+ "⬛🟨⬛🟨🟨\n"
+ "⬛🟨⬛⬛⬛\n"
+ "🟨🟨🟨🟨🟨\n"
+ "🟩🟩🟩🟩🟩\n\n"
+ "Wordle 999 X/6\n\n"
+ "🟨🟩⬛⬛⬛\n"
+ "🟨🟩⬛⬛⬛\n"
+ "🟨🟩⬛⬛⬛\n"
+ "🟨🟩⬛⬛⬛\n"
+ "🟨🟩⬛⬛⬛\n"
+ "🟨🟩⬛⬛⬛";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}