package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Wordle\s(?P<number>\d+)\s(?P<tries>[1-6X])\/6(?:\r?\n){2}(?P<evaluations>(?:[⬛🟨🟩]{5}(?:\r?\n)){0,5})(?P<result>[⬛🟨🟩]{5})`)
var str = `Tests:
Wordle 249 1/6
🟩🟩🟩🟩🟩
Wordle 251 6/6
⬛⬛⬛⬛⬛
⬛⬛🟨⬛⬛
⬛⬛🟨⬛⬛
⬛🟩🟩🟩⬛
⬛⬛⬛⬛⬛
🟩🟩🟩🟩🟩
Wordle 247 1/6
🟩🟩🟩🟩🟩
Wordle 1 5/6
⬛⬛⬛⬛⬛
⬛🟨⬛🟨🟨
⬛🟨⬛⬛⬛
🟨🟨🟨🟨🟨
🟩🟩🟩🟩🟩
Wordle 999 X/6
🟨🟩⬛⬛⬛
🟨🟩⬛⬛⬛
🟨🟩⬛⬛⬛
🟨🟩⬛⬛⬛
🟨🟩⬛⬛⬛
🟨🟩⬛⬛⬛`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}